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Risolvere i problemi relativi al codice di errore AksCapacityHeavyUsage

Questo articolo illustra come identificare e risolvere l'errore AksCapacityHeavyUsage che può verificarsi quando si crea un cluster del servizio Azure Kubernetes.

Sintomi

Quando si tenta di creare un cluster del servizio Azure Kubernetes, viene visualizzato il messaggio di errore seguente:

Codice: AksCapacityHeavyUsage

Messaggio: AKS sta riscontrando un utilizzo elevato nella regione <Region>. Stiamo lavorando per aggiungere una nuova capacità. Nel frattempo, considerate di creare nuovi cluster AKS in un'area diversa. Per un elenco di tutte le aree di Azure, visitare https://aka.ms/aks/regions. Per altri dettagli su questo errore, visitare https://aka.ms/akscapacityheavyusage.

Causa

Si sta tentando di creare un cluster in un'area con capacità limitata.

Quando si crea un cluster AKS, Microsoft Azure alloca le risorse di calcolo alla sottoscrizione. Si potrebbe occasionalmente riscontrare l'errore a causa di una crescita significativa della domanda di servizio Azure Kubernetes in aree specifiche.You might occasionally experience the AksCapacityHeavyUsage error because of significant growth in demand for servizio Azure Kubernetes in specific regions.

Risoluzione

Soluzione 1: Selezionare un'area diversa

La soluzione più semplice e rapida consiste nel cercare di eseguire la distribuzione in un'area diversa (ad esempio, NorthEurope anziché WestEurope o EMIRATI Arabi UnitiNorth anziché QatarCentral). Per trovare le aree vicine, visitare la pagina Aree geografiche di Azure.

Questo approccio potrebbe non essere fattibile se si dispone già di risorse esistenti nell'area richiesta, ma è la soluzione preferita in uno scenario di sviluppo/test.

Soluzione 2: Distribuire un cluster con impostazioni diverse

L'infrastruttura che ospita i cluster gestiti da AKS (Azure Kubernetes Service) ha prenotazioni di allocazione diverse. Di conseguenza, il servizio Azure Kubernetes potrebbe avere una capacità maggiore per i cluster pubblici rispetto ai cluster privati. Se si verifica l'errore AksCapacityHeavyUsage quando si tenta di creare un cluster privato, provare a creare invece un cluster pubblico (o viceversa).

Soluzione 3: Usare una sottoscrizione di Azure Enterprise

Quando la capacità è in esaurimento, le sottoscrizioni senza Enterprise Agreement (EA) sono soggette a limitazioni in fase iniziale nella creazione dei cluster di Azure Kubernetes per riservare risorse per scenari di produzione reali. Se hai una sottoscrizione EA, assicurati di usare la sottoscrizione EA per creare il cluster AKS.

Soluzione 4: Ripetere l'operazione

La capacità viene spesso recuperata quando altri utenti interrompono o eliminano i cluster AKS. Pertanto, l'operazione potrebbe avere esito positivo se si ritenta in un secondo momento.

Altre informazioni

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In caso di domande, è possibile porre domande al supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.