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Impossibile visualizzare l'elenco di utenti o gruppi quando si aggiungono autorizzazioni in Controllo di accesso nel portale di Azure

Questo articolo fornisce informazioni su un problema in cui non è possibile visualizzare l'elenco di utenti o gruppi quando si aggiungono autorizzazioni in Controllo di accesso (IAM) nel portale di Azure.

Versione originale del prodotto: Azure
Numero KB originale: 4229970

Sintomi

Quando si tenta di aggiungere autorizzazioni in IAM nella portale di Azure, non è possibile visualizzare l'elenco di utenti o gruppi.

Causa

Questo problema si verifica perché l'account usato per accedere a portale di Azure non dispone dell'autorizzazione di enumerazione. Questo account potrebbe essere un utente guest che è stato invitato alla directory che si sta tentando di concedere l'accesso ad altre risorse di Azure. Anche se l'utente guest è un amministratore globale, non avrà ancora l'autorizzazione di enumerazione.

Risoluzione

Per risolvere questo problema, scegliere una delle alternative seguenti:

Metodo 1: per consentire tutti i privilegi di enumerazione degli utenti guest

  1. Accedere al portale di Azure usando l'amministratore globale.
  2. Se applicabile, passare alla directory in cui è stato aggiunto l'utente guest.
  3. Passare a Microsoft Entra ID.
  4. Passare a Impostazioni utente.
  5. Modificare l'impostazione Autorizzazioni utenti guest su No e quindi selezionare Salva.

Metodo 2: per consentire solo l'utente guest o la configurazione per ogni utente

  1. Assicurarsi che Microsoft Graph PowerShell sia installato.

  2. Usare il Connect-MgGraph comando per accedere con gli ambiti necessari. Per altre informazioni, vedere Inizia a usare Attività iniziali con Microsoft Graph PowerShell SDK.

  3. Eseguire il cmdlet Update-MgUser :

    Update-MgUser -UserId '0ba17ca9-0000-0000-0000-a5e34bc4803b' -UserType Member
    

    È possibile ottenere l'ID oggetto degli utenti esaminando la pagina Profilo utenti all'interno del portale di Azure.

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